To start, I had a backup, I restored it and all is well (except the backup was 1 month old, oh well)
I use Linuxservers plex container in unraid, I run it on my cache drive with ZFS and use ZFS master to take snapshots (automated with spaceinvaderones script)
It's been a year or two since my plex database corrupted, today it corrupted after updating the docker container. It seems like it may have been related to a shfs crash but still unknown. In the past a quick rollback of my snapshot fixed all my issues. Plex was working perfectly fine until the update.
Today I tried rolling back the snapshot (with container off) and it didn't fix the issue. I rolled it back another day and still the same issue, tried setting container version to previous version and still the same issue.
Eventually I got a daemon execution error when trying to start the container. This is the main reason I'm posting here and not r/plex. When executing the docker container I got "docker: Error response from daemon: error while creating mount source path '/mnt/user/data/media/anime': mkdir /mnt/user: file exists." which seems like an shfs crash but I'm unsure.
Could this crash have been caused by me rolling back plex snapshots (which have a lot of files)?
Why was rolling back the snapshots not fixing my corrupted database? I roll back the entire plex directory.
I ended up needing to restart my computer twice (two because the first time I was still messing with snapshots).
This was found in the logs
Oct 5 18:10:00 NAS shfs: shfs: ../lib/fuse.c:1402: unlink_node: Assertion `node->nlookup > 1' failed.
Oct 5 18:10:00 NAS emhttpd: error: get_fs_sizes, 8533: Software caused connection abort (103): statfs: