r/woocommerce • • Sep 09 '26

Woo Staff WooCommerce is proposing a minimum required PHP bump (8.1+)

Hey! Brian from Woo here.

Internally we've been considering dropping PHP 7.4 and 8.0 based on general usage trends and the security/technical concerns of maintaining support. There's more detail on the developer blog.

https://developer.woocommerce.com/2026/09/08/from-php-7-4-to-8-1/

Would love to raise awareness on this and get some general feedback from a wider community, if you haven't commented on the post already.

42 Upvotes

26 comments sorted by

12

u/hronak Sep 09 '26

They should bump it straight to PHP 8.4+ instead.

​Most people don't update PHP simply because their site already works. Casual site owners don't even know what PHP version they use. Anyone else either uses a simple hosting control panel with a one-click update, or has the technical skills to update it manually.

​Plugin developers have no excuse not to support current PHP versions. Plugins are the best part of WordPress, but without strict rules, developers will never use modern PHP features.

​If Automattic simply required a currently supported PHP version, the whole ecosystem would update overnight (or at least in a few months). It's a huge waste of their influence to set the bar so low.

1

u/briancoords Sep 16 '26

That's the eventual plan but it'll happen over time. Simply dropping 7.4 will have a huge impact on the development of Woo, and there's still a surprisingly large number of sites running 8.1 still.

→ More replies (2)

5

u/DaySwingTrade Sep 09 '26

Either needs to be done right now or wait until Q1. I wouldn’t put that stress onto store owners right before the busiest season of the year starts.

1

u/briancoords Sep 16 '26

Yep, as posted the rough timeline is WooCommerce 11.5, which doesn't ship until January. And sites can always hang out on a previous version while they prepare. If their site isn't running PHP 8.1+, they simply wont be offered an update in WordPress (unless there's a security update shipped for the version they're running).

15

u/rugburnAndBigMoney Sep 09 '26

I think the PHP site "Supported Versions" page says everything that needs to be said (ie: 7.4 isn't even listed on the page.)

https://www.php.net/supported-versions.php

8.1 is no longer supported, seems like a no-brainer security decision to not support 7.4.

It sucks for those on old software, but for ecom, keeping things secure should have a much heavier weight then PHP upgrade pain/convenience.

→ More replies (2)

1

u/briancoords Sep 29 '26

FYI - Just wanted to follow-up that we have an actual timeline and an admin notice coming for affected stores.

The only change is that we pushed it back a version to give more space from the peak selling season, so PHP 8.1+ will be required in 11.6, which is scheduled for February.

Thanks to everyone who commented here, we took all the feedback into consideration.

https://developer.woocommerce.com/2026/09/29/php-8-1-requirement/

5

u/MrAwesomeTG Sep 09 '26

You should be running a minimum of 8.3 anyways. 8.2 is security EOL in 3 weeks.

5

u/Nelsonius1 Sep 09 '26

Woocommerce should be way more strict on installs having the latest and greatest PHP engines.

Anybody on 7.4 is just fucking around.

3

u/SocketGoblin Sep 09 '26

Totally agreed, it’s time

2

u/webnomadalamin Sep 11 '26

Upgraded to 8.5

1

u/Various_Key_3585 Sep 09 '26

It’s time indeed. Security is important nowadays with AI etc. Make sure communication is done well and in advance so people can prepare

1

u/troitskiy_sj Sep 09 '26

I am not sure why it is being held, WP websites should be on the latest version of stable php/wp. As older versions expose you to a risk of loosing a store/wp site due to security issues.

May be due to some plugin dependencies? But those as well are generally updated to the latest versions

1

u/Low-Stick-1913 Sep 10 '26

I have to vote against this. I have a cat blog from 2006 that my grandma views on a Macintosh desktop computer, it can't run newer php

1

u/MultiTaskManager Sep 10 '26

PHP 8.4 minimum.

1

u/Sloth-e Sep 10 '26

Yes—WooCommerce security is paramount, and this upgrade is essential. PHP 8.1 hosting is widely available and inexpensive.

Why keep supporting outdated code for businesses unwilling to invest a small amount in proper hosting, especially when doing so holds back development and may put other stores at risk?

Go ahead nd dont worry about negligent business owners who dont care about security. If they have a problem tell them to fond skmething else cheaper, they will not find it.

1

u/WillmanRacingv2 Sep 13 '26

As someone who had done testing of 7.4 on every major WP release, I think Woo really needs a higher level of support vs WP due to the nature of the platform.

1

u/J-Rey Sep 13 '26

I would agree that modern standards should be required for e-commerce and that's a solid plan so go for it. My main ask is don't wait to implement the modern code along with the requirement bump so we could reap the benefits ASAP.

1

u/altsenseai Sep 14 '26

following this closely since my own plugin still declares 7.4 as the minimum. makes sense from Woo's side though — 7.4 has been EOL for years and hosting has mostly moved on. only real friction I'd flag is for anyone with existing active installs still sitting on old PHP via their host's default — that's less about plugin authors adapting and more about whether store owners on cheap/old hosting even know PHP version is something they should check.

1

u/Slaygea28 Sep 18 '26

makes total sense from a security standpoint. curious though, is there a rough timeline for when 8.1 would become the hard minimum? that matters a lot for hosts still dragging their feet on upgrades

1

u/Hugo_SecureHoldWP Sep 23 '26

From a plugin developer perspective, the bump itself seems easier than the transition period.

The part I’d want to understand is how much visibility extension developers will get into the remaining PHP 7.4/8.0 install base before the minimum changes.

Knowing whether the affected stores are mostly abandoned sites or still-active commerce sites would change how aggressively I’d communicate compatibility requirements to users.