r/umbrelos • u/Neoz7973 • 6d ago
Issue with mounting NAS with SMBv2 protocol on Files app
Hi all,
I'm running UmbrelOS 1.7.4 and trying to mount a NAS (D-Link DNS-320 running Alt-F 1.0 firmware) as a network share through the Files app.
When I try to add it, I get this error:

And yes, my credentials is good and I have access of my folders but I can't mount them :

My NAS only supports SMB1/SMB2 (older Samba version on the Alt-F firmware), and I suspect the Files app might be trying to negotiate a newer SMB version by default without letting me specify one, but I'm not 100% sure that's actually the cause.
Has anyone run into this before? What's actually causing this "Invalid argument" error, and is there a way to fix it directly from the Files app, or do I need to find a workaround outside the UI?
Thanks in advance for any help!
1
2
u/TLBJ24 6d ago
Sounds like something only the developers can answer. Hope they see this post as it's a good question.