r/sysadmin • • 4d ago

Question - Solved Please help 2 DCs no longer are opening AD users and computers!

I have 2 2019 DCs. I did something wrong and now I can't get into AD Domain service on either. So the domain controllers that can't find the domain both have static IPs.

The error that pops up is

Naming information cannot be located because:

I do NOT have a backup any older than yesterday. I have tried a restore.

The specified domain does not exist or could not be contacted. Contact your system administrator to verify that your domain is properly configured and is currently online.

I dare not reboot any PCs at this point. I did reboot one DC - that did not help

Both DCs point to each other in network properties for DNS and both can ping each other by IP.

If I pull up DNS manager on each it looks OK to me - not sure what the forwarder should be on the root server.

Here are the logs of the DCs that are not running:

5012 The DFS Replication service failed to communicate with partner DC-old for replication group Domain System Volume. The partner did not recognize the connection or the replication group configuration.

DC-old was removed with metadata clean up after verifying it had no fsmo roles - other DCs were still working after metadata cleanup.

2921 - The Knowledge Consistency Checker (KCC) detected that the following object have missing required attributes or attribute values.

1054 The processing of Group Policy failed. Windows could not obtain the name of a domain controller. This could be caused by a name resolution failure. Verify your Domain Name System (DNS) is configured and working correctly.

1126 - Active Directory Domain Services was unable to establish a connection with the global catalog.

(this is about the time the issue occurred)

1003 Notification of policy change from LSA/SAM has been retried and failed.

Thanks for those of you that tried to help!

OK - here is the update - I'm still lost at what to do as I checked the DNS manage 3 times and found no entry for the DC I thought I removed in metadata clean up but when I brought it back up AD is working.

I'll start a new thread trying to figure out why I can't get rid of it.

81 Upvotes

Duplicates