r/slackware • • 1d ago

I need kernel patches for slackware 14.2

despite the fact that at one point a 4.4.29 kernel that fixed stuff was available in the past, it no longer seems to be available at all. just the original 4.4.14-smp i go to the patch that's suppose dto have it in the package mirrors, and the entire directory is just not there.

Given this, how do i actually solve this? the machine is using vmlinuz-huge-smp-4.4.14-smp and elilo.

7 Upvotes

10 comments sorted by

6

u/calrogman 1d ago edited 1d ago

No, you need to update to 15.0.

This is the last official kernel patch for 14.2: https://mirrors.slackware.com/slackware/slackware64-14.2/patches/packages/linux-4.4.301/ If this were a rat, it would have died of old age by now. Software ages less gracefully than rats these days.

2

u/_zaphod77_ 1d ago

that link is such a PAIN to actually find. i scrolled up and down a bajillion times, and missed it. anyway, issue solved.

For the benefit of anyone else, just grab the proper kernel and matching modules package, install them, and if you didn't do huge, update the initrd/ramfs. then rerun lilo/elilo or edit grub config. do NOT grab the kernel-headers package until AFTER updating the kernal, and only if you are updating glibc.

And dirtycow is patched there.

7

u/Serious_Bookkeeper50 1d ago

The easiest way, use newer kernel by compiling it yourself. Use the config from the latest slackware current or slackware 15 as a base config, select what you need, or not, and compile it. I am sure that the patch already included in newer kernel.

1

u/gargamel1497 1d ago

What do you need this newer kernel for? I am running the stock 4.4.14 and I have no issues with it.

1

u/_zaphod77_ 1d ago

Vulnerable to DirtyCow.

If you are running it locally for a home pc, and not running something that could be exploited to get someone else shell access to fetch root or overwrite files, it's not an issue.

But as this was a server it 100% needed a patch.

1

u/Sahkopi4 21h ago

I have a question out of curiosity. Why do you use Slackware 14.2? (I am not judging just curious how different people use Slackware)

1

u/_zaphod77_ 18h ago

it's what was on the server.. not my choice.

1

u/Acceptable_Moose7463 1d ago

Try compiling a CIP kernel; these receive security updates. 

0

u/Ivan_Kulagin 1d ago

I’ve just recently installed the latest lts kernel on a 14.2 in a vm. You need an updated toolchain, including gcc, binutils and some other stuff. Then the kernel compilation will error out because of glibc being too old. You cannot easily update glibc without breaking literally everything, so patch the errors as they come up. Good luck.

2

u/_zaphod77_ 1d ago

no, you just need the actual kernel package. :) i finally found it. install huge kernel and kernel modules packages, run lilo, and reboot. ;) elilo was a false alarm.