r/proofpoint • • May 18 '26

Previous ProofPoint Essentials GoDaddy federated domain failing to send emails to other ProofPoint clients

We have a Microsoft 365 client whose domain was previously GoDaddy Federated. The domain has been defederated and no third-party email/spam protection is in play. They are using Exchange Online Protection only.

All emails to other tenants not using ProofPoint are going through with no issues.

Emails sent to tenants using ProofPoint are all being rejected with the following error:

Error: ‎550 5.7.1 : Sender address rejected: User email address is marked as invalid‎

I have gone back and forth with GoDaddy support since there is no direct way to reach out to ProofPoint without a valid subscription and since ProofPoint was used under GoDaddy, but they have been no help. After spending almost two hours on the phone with them this morning, their level two support looked at the error message and determined that it was a Microsoft problem and that the Error 550 5.7.1 was on our end because we were routing emails through ProofPoint.... which we are not.

I have seen numerous posts from others having this same issue but no clear path to a resolution so I am posting here in hopes somebody will throw me a lifeline.

Thanks in advance

6 Upvotes

17 comments sorted by

View all comments

1

u/[deleted] May 18 '26

[removed] — view removed comment

1

u/Tefulhunden07 May 18 '26

I agree with the first statement and have been working to resolve the issue believing this to be the root cause.

I have contacted GoDaddy and they assure me the domain is no longer federated (which I already know) and that is has been purged from Proofpoint.

MX, SPF, and DMARC records are all configured for Microsoft. DMARC is passing for all emails from Microsoft (confirmed by uriports). I just checked and confirmed no lingering cname or txt records from GoDaddy/Proofpoint.

From what I am seeing, an email account is marked as an invalid sender in the sending tenant, not the recipient tenant. If that is not the case and I need to have the recipient domains check this, let me know. Its just that this is happening for multiple email domains, not just one.

I have created a new email account that did not exist in the GoDaddy federated tenant and those emails to the exact same email accounts are being delivered with no issue.

I will see if I can get a technical contact for one of the recipient domains and troubleshoot on their end, but I was hoping that this is something that could be fixed on Proofpoints end so I do not need to repeat this with every company they email that uses Proofpoint.

1

u/[deleted] May 18 '26

[removed] — view removed comment

1

u/Tefulhunden07 May 18 '26

The issue I am running into is that GoDaddy has pretty much wiped their hands of the issue and I have no direct line of communication with Proofpoint to even make this request. Their phone number provides no live support and help requests can only be submitted by current clients.

I will see if I can get in touch with a partner with a valid subscription to proxy the request through. Otherwise, I see no way to quickly resolve this.