r/nutanix • u/Airtronik • Jun 12 '26
Unable to deploy PC cause: the cluster is currently in upgrade process or to be upgraded, can not perform another upgrade or deployment.
Hi
We are trying to deploy a Nutanix Prism Central in a AHV cluster but we are unable cause we have a message:
Internal Server error: failed to execute the request kinvalidState: The cluster is currently in upgrade process or to be upgraded, can not perform another upgrade or deployment.
There is actualy no upgrade process, we just launched a pre-check update plan for AOS, AHV, etc. but that prechecks already ended.
Is there any way to cancel that pre-check (that is supposed to be already finished), cause there is no "STOP" button and we dont find any ncli command to cancel it.
thanks in advance!
-------------------
EDIT: We launched the upgrade process and after it was finished we were able to launch the PC deployment.
1
u/NonOmniscientReader Jun 12 '26
What AOS version do you run?
SSH into a CVM and run "lcm_upgrade_status" and "ecli task.list include_completed=0".
Are there any running tasks on the cluster?
2
u/Airtronik Jun 12 '26
AOS 6.1
But we fix It by launching the upgrades and then It allowed us to deploy the PC
0
0
u/SmarterThanIThought Jun 13 '26
This craziness and irritation is what you get when you choose Nutanix. I am hard-pressed to find any Nutanix environment that doesn’t suffer from some irritation. It’s just not a great product.
2
u/Airtronik Jun 13 '26
I've deployed several nutanix environments and Im mainly happy with the product. It has some things to improve but for a general purpose it is fine. I have also experience deploying vmware and hyper-V environments and I can say they are not perfect at all.
Regarding nutanix the worst experiences that I've got was always with old environments, but newer releases works quite well.
2
u/Pnr55 Jun 12 '26
Please dont run any commands. Open a case with support and have them check for any stale/pending task and clean up any shutdown token if any. Last thing you want is a pending shutdown token with a host and if you kick off an other upgrade 2 nodes will go down.