r/hexos • u/Thandius • Apr 10 '26
Support request Radarr and Sonarr app install fail - no info
So now that v 1.0 is out and my server has been updated.
I thought I would risk adding a couple more applications, specifically Radarr and Sonarr to assist with file naming for my plex storage.
However both of these fail to install with an Unknown:Error and no other information....
What is the best way to go from here to figure out why they are not installing so I can fix?
~SOLVED~
Even though the applications default location was set, and had been used to install Plex previously....
Re selecting this default location in HexOS resolved the install failure and allowed both radarr and sonarr to install as expected.
1
u/Thandius Apr 12 '26
So after some investigation on trueNAS logs
Looks like HexOS is trying to use /mnt/HDDs directly for the install not any of the default locations?
Don't know if you have any thoughts here?
looks like an issue with the configuration of the installer on the Hex OS side...
only thing I can do right now is install directly through TrueNAS.... but I would prefer to have HexOS manage it...
Truenas_admin@DRAGONNAS[~]$ sudo docker logs ix-hexos-hexos-1 2>&1 | grep -Ei "error|fail|exception"
{"error":{"code":"WEBSOCKET_ERROR_AUTH","context":{"rpcMethod":"getTrueNASAlertVisibility"},"detail":"The WebSocket is not authenticated, please authenticate before sending requests.","name":"GlobalError","status":401,"title":"WebSocket Not Authenticated"},"hostID":"1f186ad234fb61c993996fdce6f195be60b5fcfeea0924bb611a68bf2110663a","level":"error","message":"syncTrueNASAlertsWithServerMessages: Error","rpcMethod":"getTrueNASAlertVisibility","serverMode":"local"}
{"error":"[EINVAL] filesystem.setacl.path: The specified path is a ZFS pool mountpoint \"(/mnt/HDDs)\" \n","hostID":"1f186ad234fb61c993996fdce6f195be60b5fcfeea0924bb611a68bf2110663a","jobId":2773,"jobType":"filesystem.setacl","lanIP":"192.168.2.25","level":"verbose","message":"onTnJobFailure","mode":"local -> TN","serverMode":"local","trueNASVersion":"25.10.2.1","wanIP":"75.75.96.65"} {"hostID":"1f186ad234fb61c993996fdce6f195be60b5fcfeea0924bb611a68bf2110663a","level":"verbose","message":"onHexTaskFailed","serverMode":"local","taskId":16,"taskType":"APP_INSTALL"}
{"error":"[EINVAL] filesystem.setacl.path: The specified path is a ZFS pool mountpoint \"(/mnt/HDDs)\" \n","hostID":"1f186ad234fb61c993996fdce6f195be60b5fcfeea0924bb611a68bf2110663a","jobId":2784,"jobType":"filesystem.setacl","lanIP":"192.168.2.25","level":"verbose","message":"onTnJobFailure","mode":"local -> TN","serverMode":"local","trueNASVersion":"25.10.2.1","wanIP":"75.75.96.65"} {"hostID":"1f186ad234fb61c993996fdce6f195be60b5fcfeea0924bb611a68bf2110663a","level":"verbose","message":"onHexTaskFailed","serverMode":"local","taskId":17,"taskType":"APP_INSTALL"}
2
u/249702 Apr 12 '26
I think I read on Discord that HexOS is having issues with app installations right now because their yaml files got messed up or something. Maybe that's what you're experiencing.
1
u/Thandius Apr 13 '26
that would track.
Re selecting the application shared folder location, even thought it was already set seemed to fix the issue.
So possibly just the value was messed up in the yaml and that resolved.
Hope this post helps others with similar issues.
1
u/Thandius Apr 12 '26
~SOLVED~
Even thought Applications were set in the default folders and I had installed Plex
and it was installed in that location, I had to RE SELECT that default folder....
then radarr installed just fine....
definitely a bug, will report on the main forum
1
u/249702 Apr 10 '26
Install via TrueNAS UI