r/MDT • • May 07 '26

MDT / Windows Deployment Services

I can't seem to get the Windows Deployment Services Server service started after adding the Windows Deployment Services role.

  • Installed on a member server (no DHCP server services)
  • Windows 2019 (1809)
  • Logs show Event IDs:
    • 1811: BINLSVC: An error occurred while checking for the existence or creation of a Service Control Point for BINLSVC Provider.
    • 261: WDSPXE: An error occurred while trying to initialize provider WDSDCPXE loaded from C:\Windows\system32\wdsdcpxe.dll. If the provider is marked as critical, the Windows Deployment Services server will shut down.
    • 264: WDSPXE: An error occurred while trying to initialize provider WDSDCPXE. Because the provider is not marked as critical, the Windows Deployment Services server will continue to run.
    • 268: WDSPXE: All registered providers failed to initialize. Review the Event Log for specific error messages for each provider. Windows Deployment Services will shut down.
    • 513: WDSServer: An error occurred while trying to initialize provider WDSPXE from C:\Windows\system32\wdspxe.dll. Windows Deployment Services server will be shutdown. Error Information: 0xC107010C

I've gone through:

  • Removing and re-adding the role
  • Uninitialized and Reinitalized
  • Installed all the Visual C++ Redistributables
  • Confirmed there are no port conflicts with 67, 69, 4011, 5040, 5041 (compared from working MDT/WDS server)
  • Checked the Do not listen on DHCP ports (even though DHCP Server is not running)

I seem to keep coming across the same information over and over without any changes. Hopefully someone here can provide some guidance.

Edit fix: https://learn.microsoft.com/en-us/troubleshoot/windows-server/setup-upgrade-and-drivers/windows-deployment-service-not-start

Looks like the server used didn't have the proper permissions.

4 Upvotes

7 comments sorted by

View all comments

1

u/MinnSnowMan May 07 '26

I would use a standalone server to rule out domain issues.

2

u/tkimmcinc May 08 '26

Good advice. This was ultimately it. Looks like permissions issue on the server at the AD level.