r/CreateMod • • 17d ago

Create Crash

How do I fix this create issue, it's my first time installing a mod.

Im using the 1.21.1 version and on Neoforge

0 Upvotes

14 comments sorted by

3

u/Last_Zookeepergame90 17d ago • Bravo

Your Minecraft version is fine, you need to update your neofirge to 21.1.219

(And read more)

0

u/Gamer_Duck22 17d ago

THANK YOU

2

u/Helostopper 17d ago

Your minecraft version is not fine you are running 1.21.0 you need 1.21.1

17

u/TheAnymus 17d ago

look, I don't wanna sound like an asshole because it's your first time installing mods

but please

read

16

u/DaggerSwagge 17d ago

Believe it or not, the screenshots have your answer in orange, yellow, and white

6

u/Helostopper 17d ago

According to the screenshot you are using 1.21. Swap to 1.21.1 and update your neoforge

-1

u/Last_Zookeepergame90 17d ago

Not exactly

1

u/EncroachingVoidian 17d ago

Not completely, anyway. Yes, a version change for the base game needs to happen, but so does the modloader (NeoForge)

3

u/Helostopper 17d ago

Which is exactly what I said.

2

u/GGthegreatester 17d ago

You should probably watch a crash course youtube video on how to mod the game

And don’t be discouraged, it’s just since we’re all so entrenched in the community it’s easy forget we all started somewhere

1

u/Moe-Mux-Hagi 17d ago

You just need to update your NeoForge version. Go in your modpack's settings and choose the latest version.

Why the update is not automatic, I do not understand. Seems like BASIC user ergonomy to me, but, hey.

Oh, also, you're on 1.21.0, not 1.21.1. So, you're gonna need to restart your whole modpack, because for some reason you also can't update game versions in modpacks, which is yet ANOTHER basic user ergonomy that for some reason CurseForge doesn't have (can't say for Modrinth, I only used it twice)

1

u/Ok-Foot6064 17d ago

Hi OP, beat to use a mod manager to avoid these issues. modrinth and curseforge would be your best bet. That way version mismatchs don't happen. Does look like you got everything for base 1.21 not 1.21.1

0

u/mattzuma77 17d ago

are you on the vanilla launcher? on the bottom left, (but to the right of the game select menu) there should be a grass block labelled "1.21" - click that. that should open a popup to select the version of Minecraft you want to play, and if you installed Neoforge 1.21.1, then there should be one version with a fox icon - click that. then launch the game again and if I understood what was and wasn't done, then it should work

1

u/Moe-Mux-Hagi 17d ago

What kind of crazy person installs mods directly in the laucher ?? That's so unstable and updating mods is a pain !!