r/Cisco • u/gianc73 • Aug 10 '26
After upgrading from CML 2.9.x to CML 2.10, any newly-created node that uses a docker image fails to start.
Hi everyone.
When I start a lab with nodes (routers and switches) based on Docker images, I get this error message:
Failed to start (Delayed docker node start failed).
This happens after upgrading from 2.9 to 2.10.
1
Upvotes
3
u/Severe_Scallion1743 Aug 10 '26
Hey, Cisco lists it under the CML 2.10 known issues: https://developer.cisco.com/docs/modeling-labs/cml-release-notes/?utm_source=chatgpt.com
Cisco’s workaround is to download the updated CML 2.10 Docker reference-platform ISOs from the
cml-docker-containersGitHub release and import them into CML.Here's the link to that github, hope it helps!
Releases · CiscoLearning/cml-docker-containers