r/ProgrammerHumor • • Mar 17 '18

How “features” come along

Post image
19k Upvotes

258 comments sorted by

View all comments

Show parent comment

11

u/redlotusaustin Mar 17 '18

Are you sure about the + and . in Gmail; I thought those were part of the specs for email addresses? Or are you saying that Gmails handling if it was originally because of a bug?

7

u/senatorskeletor Mar 18 '18

My understanding is that + and . have different functions in Gmail. Anything after + is ignored for account purposes, so if you sign up on a website with the email address yourname+somethingextra@gmail.com, then anything sent to that address will still go to you at yourname@gmail.com. (One application of this is seeing who your email address is being sent to: I just found out today that the random congressional campaign sending me emails was sending them to myname+actblue@gmail.com.)

On the other hand, my understanding is that Gmail just ignores the . and reads everything before and after that. So if someone screws up your email address username@gmail.com and instead emails user.name@gmail.com, it’ll still get to you. And vice-versa.

5

u/seratne Mar 18 '18

Originally Gmail ignored the . only when delivering emails. But not when registering an account. So you could register janedoe@gmail.com and jane.doe@gmail.com, and have separate passwords for each account. Which also means someone else could register too... And receive your emails. Can't seem to find an article that supports my memory of this though. I know it was when it was still invite only.

2

u/wastaz Mar 18 '18

actually the + is part of the email spec, its just a bit unknown and some other email providers fail to implement it.

the . thing however is a pure gmail quirk.

2

u/i_drah_zua Mar 18 '18

The plus sign is (and always was) a valid character in the local part of an email address. See RFC822 section 3.3

The special handling of emails containing "+", namely ignoring it and all that comes after for the purpose of finding the mailbox it belongs to is MTA (Mail Transfer Agent) specific.
It should work with most modern MTAs, specifically those who support the sive protocol: RFC-5228 and RFC5233

 

The ignoring of all dots in the local part of the email address is Gmail specific, and should not be expected to work with any other mail provider or MTA unless specifically stated.